Print Friendly

WordPress  version 4.7.5 has be released to address multiple vulnerabilities in earlier versions. Users and administrators are recommended to upgrade wordpress version before the vulnerabilities are exploited and attackers take control of your site.

For more details and necessary action please visit: WordPress 4.7.5 .